- Aktif istismar
- Yama var
- CWE-77
- CWE-78
CVE-2026-42271
LiteLLM'de MCP stdio test uç noktaları üzerinden kimliği doğrulanmış komut çalıştırma açığı
- Yayımlandı
- Güncellendi
- 26 Eki 2026
- Açık yaşı
- 173 gün
- Kaydı açan
- GitHub_M
ÖzetTürkçe
LiteLLM, OpenAI (veya yerel) biçimindeki LLM API'lerini çağırmak için kullanılan bir proxy sunucusudur (AI Gateway). 1.74.2 sürümünden 1.83.7 sürümünden önceki sürümlere kadar, bir MCP sunucusunu kaydetmeden önce önizlemek için kullanılan iki uç nokta — POST /mcp-rest/test/connection ve POST /mcp-rest/test/tools/list — istek gövdesinde command, args ve env alanları dahil olmak üzere tam bir sunucu yapılandırmasını kabul ediyordu; bunlar stdio taşıyıcısı tarafından kullanılır. stdio yapılandırmasıyla çağrıldığında, uç noktalar bağlantı kurmaya çalışıyor ve verilen komutu proxy ana bilgisayarında, proxy sürecinin ayrıcalıklarıyla bir alt süreç olarak başlatıyordu. Uç noktalar yalnızca geçerli bir proxy API anahtarıyla korunuyordu, rol kontrolü yoktu. Bu nedenle, düşük yetkili dahili kullanıcı anahtarlarına sahip olanlar dahil, kimliği doğrulanmış her kullanıcı ana bilgisayarda rastgele komutlar çalıştırabiliyordu. Bu sorun 1.83.7 sürümünde giderilmiştir.
Kaynaktaki açıklama (İngilizce)
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.
CISA'nın önerdiği eylem (İngilizce)
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Bu açığın açıklamasını Türkçeye çevirdik. Adım adım çözüm önerilerini kritik ve yeni açıklar için hazırlıyoruz; düzeltilmiş sürüm aşağıdaki tabloda, ayrıntılar üreticinin duyurusunda.
Etkilenen sürümler3 yazılım
| Yazılım | Etkilenen | Düzeltildiği sürüm |
|---|---|---|
| BerriAI LiteLLM | Sürüm belirtilmemiş | – |
| litellm | ≥ 1.74.2, < 1.83.7 | 1.83.7 |
| redhat Openshift Ai | ≥ 2.25, < 2.25.8 | 2.25.8 |
| ≥ 3.3, < 3.3.4 | 3.3.4 | |
| 3.4 | – |
Kaynaklar11 kaynak
- CVE.org kaydı
- NVD kaydı
- access.redhat.com/errata/RHSA-2026:27784 Üçüncü taraf
- access.redhat.com/errata/RHSA-2026:28960 Üçüncü taraf
- access.redhat.com/errata/RHSA-2026:30056 Üçüncü taraf
- access.redhat.com/security/cve/CVE-2026-42271 Üçüncü taraf
- bugzilla.redhat.com/show_bug.cgi Üçüncü taraf
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42271.json Üçüncü taraf
- github.com/…itellm/security/advisories/GHSA-v4p8-mg3p-g94g Diğer
- github.com/BerriAI/litellm/releases/tag/v1.83.7-stable Diğer
- cisa.gov/known-exploited-vulnerabilities-catalog Diğer
Kayıt geçmişi
- CISA KEV listesine eklendi (saldırılarda kullanılıyor)
- Yayımlandı
İlgili açıklar
Türkçe metin, resmi kayıtlardaki bilgilerle yapay zekâ yardımıyla yazıldı ve yayından önce otomatik kontrollerden geçti. Bir değişikliği uygulamadan önce üreticinin duyurusuna mutlaka bakın.