- Son 7 gün
- CWE-79
- CWE-94
CVE-2026-120597
Welcart e-Commerce Plugin paymentESCOTT.main.class.php error_page_message cross site scripting
- Yayımlandı
- Güncellendi
- 3 Kas 2026
- Açık yaşı
- 0 gün
- Kaydı açan
- VulDB
Özet
Türkçe özeti yalnızca kritik ve yüksek önemdeki açıklar için hazırlıyoruz. Bu açık için kaynağın kendi açıklamasını gösteriyoruz.
A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file classes/paymentESCOTT.main.class.php. Such manipulation of the argument ResponseCd leads to cross site scripting. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version 2.12.7 mitigates this issue. It is recommended to upgrade the affected component. The value is now escaped with esc_html() before output. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Etkilenen sürümler1 yazılım
| Yazılım | Etkilenen | Düzeltildiği sürüm |
|---|---|---|
| Welcart e-Commerce Plugin | 2.12.0 | – |
| 2.12.1 | – | |
| 2.12.2 | – | |
| 2.12.3 | – | |
| 2.12.4 | – | |
| 2.12.5 | – | |
| 2.12.6 | – | |
| 2.12.7 Etkilenmiyor | – |
Kaynaklar8 kaynak
- CVE.org kaydı
- NVD kaydı
- wordpress.org/plugins/usc-e-shop Yama
- vuldb.com/cve/CVE-2026-120597 Üçüncü taraf
- vuldb.com/submit/1039186 Üçüncü taraf
- github.com/bevennyamande/welcart-poc İstismar kodu ya da analiz
- vuldb.com/vuln/429933 Diğer
- vuldb.com/vuln/429933/cti Diğer
Kayıt geçmişi
- Yayımlandı