- Yama var
- Son 7 gün
CVE-2026-10859
IBM MQ XMS .NET client is affected by an arbitrary code execution vulnerability
- Yayımlandı
- Güncellendi
- 5 Kas 2026
- Açık yaşı
- 0 gün
- Kaydı açan
- ibm
Özet
Türkçe özeti henüz hazır değil; şimdilik kaynağın kendi açıklamasını gösteriyoruz.
IBM MQ 9.2.0.0 through 9.2.0.44 LTS, 9.3.0.0 through 9.3.0.42 LTS, 9.4.0.0 through 9.4.0.26 LTS, 9.4.0.0 through 9.4.5.1 CD, and 10.0.0.0 through 10.0.0.5 LTS and CD could allow an authenticated attacker to execute arbitrary code on consumer applications due to insecure deserialization of ObjectMessage payloads.
Üreticinin çözüm notu (İngilizce)
This issue was addressed under Known Issue DT472703.
IBM MQ version 9.2 LTS
Apply cumulative security update 9.2.0.46 https://www.ibm.com/support/pages/downloading-ibm-mq-92-lts
IBM MQ version 9.3 LTS
Apply cumulative security update 9.3.0.43 https://www.ibm.com/support/pages/downloading-ibm-mq-93-lts
IBM MQ version 9.4 LTS
Apply fix pack 9.4.0.30 https://www.ibm.com/support/pages/downloading-ibm-mq-94
IBM MQ version 10.0.LTS
Upgrade to IBM MQ version 10.0.0.6 https://www.ibm.com/support/pages/downloading-ibm-mq-100
IBM MQ version 9.4 CD and 10.0 CD
Upgrade to IBM MQ version 10.0.1.0 https://www.ibm.com/support/pages/downloading-ibm-mq-100
Etkilenen sürümler1 yazılım
| Yazılım | Etkilenen | Düzeltildiği sürüm |
|---|---|---|
| IBM MQ | ≥ 9.2.0.0, ≤ 9.2.0.44 | – |
| ≥ 9.3.0.0, ≤ 9.3.0.42 | – | |
| ≥ 9.4.0.0, ≤ 9.4.0.26 | – | |
| ≥ 9.4.0.0, ≤ 9.4.5.1 | – | |
| ≥ 10.0.0.0, ≤ 10.0.0.5 | – |
Kaynaklar3 kaynak
Kayıt geçmişi
- Yayımlandı