Zafiyet.live Keşfet. Değerlendir. Düzelt. Doğrula.
  • Yama var
  • Son 7 gün
  • CWE-863

CVE-2026-105930

Apache Pulsar'da paket URL'lerinde yetkilendirme eksikliği, kiracılar arası paket indirmeye izin veriyor

Apache Software Foundation Apache Pulsar

Orta 6,0 CVSS 4.0
Yayımlandı
Güncellendi
26 Eki 2026
Açık yaşı
6 gün
Kaydı açan
apache

ÖzetTürkçe

Paket yönetimi etkinleştirildiğinde, Pulsar Functions, Source ve Sink bileşenleri paket URL'si verilerek Pulsar Paket Yönetimi Hizmeti'nde saklanan bir paketten kaydedilebilir veya güncellenebilir. Pulsar Functions worker'ı bu istekleri yalnızca bileşenin kaydedildiği ya da güncellendiği ad alanına karşı yetkilendirmektedir. Ancak paket URL'sinin işaret ettiği ad alanındaki paketlere erişim izninin istekte bulunan kullanıcıda olup olmadığını kontrol etmez ve paketi broker'dan worker'ın kendi kimlik bilgileriyle alır. Dolayısıyla Paket Yönetimi Hizmeti'nin izin kontrolü, istekte bulunan kullanıcı yerine worker'ın kimliğine uygulanmış olur. Sink kaydedilirken veya güncellenirken verilen transform fonksiyonlarının paket URL'leri de aynı şekilde işlenir.

Kendi kiracısının herhangi bir ad alanında fonksiyon, source veya sink kaydetme ya da güncelleme yetkisi olan kimliği doğrulanmış bir kullanıcı, bu açığı kullanarak başka bir kiracının ad alanında saklanan bir paketin içeriğini, o ad alanındaki paket izinlerine sahip olmadan elde edebilir. Etkisi, uygulama kodu, iş mantığı veya gömülü kimlik bilgileri içerebilecek paket içeriklerinin ifşa edilmesiyle sınırlıdır. Bu sorun paketlerin değiştirilmesine veya silinmesine izin vermez ve erişilebilirliği etkilemez.

Bu sorun yalnızca kimlik doğrulama ve yetkilendirmenin etkin olduğu ve paket yönetiminin etkinleştirildiği dağıtımları etkiler; bunlar broker ayarı enablePackagesManagement ve güncel sürümlerde functions worker ayarı functionsWorkerEnablePackageManagement'tır. Her iki ayar da varsayılan olarak devre dışıdır.

Sorun, 2.8.0 ile 4.0.14 öncesi, 4.1.0 ile 4.1.3 arası (dahil) ve 4.2.0 ile 4.2.5 öncesi Apache Pulsar sürümlerini etkiler.

- 4.0.x sürümünü kullanan kullanıcılar en az 4.0.14 sürümüne yükseltmelidir.
- 4.1.x ve 4.2.x sürümünü kullanan kullanıcılar en az 4.2.5 sürümüne yükseltmelidir.

Yukarıda listelenen sürümlerden önceki sürümleri çalıştıran kullanıcılar, belirtilen yamalı sürümlere veya daha yeni sürümler…

Kaynaktaki açıklama (İngilizce)

When package management is enabled, Pulsar Functions, Sources and Sinks can be registered or updated from a package stored in the Pulsar Packages Management Service by supplying a package URL. The Pulsar Functions worker authorized these requests only against the namespace in which the component was being registered or updated. It did not check whether the requesting user was permitted to access packages in the namespace that the package URL refers to, and it retrieved the package from the broker using the worker's own credentials. The permission check of the Packages Management Service was therefore applied to the worker's identity instead of the requesting user's. Package URLs of transform functions supplied when registering or updating a sink were handled in the same way.

An authenticated user who is permitted to register or update functions, sources or sinks in any namespace of their own tenant could use this to obtain the contents of a package stored in a namespace of another tenant, without having the packages permission on that namespace. The impact is limited to disclosure of package contents, which may include application code, business logic or embedded credentials. The issue does not allow packages to be modified or deleted and does not affect availability.

This issue only affects deployments that have authentication and authorization enabled and in which package management has been enabled: the broker setting enablePackagesManagement and, in current releases, the functions worker setting functionsWorkerEnablePackageManagement. Both settings are disabled by default.

This issue affects Apache Pulsar versions from 2.8.0 before 4.0.14, from 4.1.0 through 4.1.3, and from 4.2.0 before 4.2.5.

- 4.0.x version users should upgrade to at least 4.0.14.
- 4.1.x and 4.2.x version users should upgrade to at least 4.2.5.

Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

The currently supported Apache Pulsar release lines are 4.0.x and 5.0.x. The supported versions schedule is available at https://pulsar.apache.org/contribute/release-policy/.

Bu açığın açıklamasını Türkçeye çevirdik. Adım adım çözüm önerilerini kritik ve yeni açıklar için hazırlıyoruz; düzeltilmiş sürüm aşağıdaki tabloda, ayrıntılar üreticinin duyurusunda.

Etkilenen sürümler1 yazılım

YazılımEtkilenenDüzeltildiği sürüm
Apache Software Foundation Apache Pulsar ≥ 2.8.0, < 4.0.14 4.0.14
≥ 4.1.0, ≤ 4.1.3 –
≥ 4.2.0, < 4.2.5 4.2.5

Kaynaklar4 kaynak

Kayıt geçmişi

  1. Yayımlandı

İlgili açıklar

Türkçe metin, resmi kayıtlardaki bilgilerle yapay zekâ yardımıyla yazıldı ve yayından önce otomatik kontrollerden geçti. Bir değişikliği uygulamadan önce üreticinin duyurusuna mutlaka bakın.