Zafiyet.live Keşfet. Değerlendir. Düzelt. Doğrula.
  • Aktif istismar
  • Yama var
  • CWE-290

CVE-2022-24112

Apache APISIX batch-requests eklentisinde IP kısıtlamasını aşma ve uzaktan kod çalıştırma

Apache Software Foundation Apache APISIX

Kritik 9,8 CVSS 3.1
Yayımlandı
Güncellendi
22 Eki 2025
Açık yaşı
1720 gün
Kaydı açan
apache
Saldırılarda kullanılıyor CISA, bu açığın gerçek saldırılarda kullanıldığını doğruladı ve 25 Ağu 2022 tarihinde KEV listesine ekledi. ABD kamu kurumlarına verilen son yama tarihi: 15 Eyl 2022.

Yönetici özeti

Bu açık, saldırganın herhangi bir giriş yapmadan API ağ geçidi sunucusunu ele geçirmesine izin verebilir ve aktif olarak istismar edildiği bilinmektedir. Güncelleme veya eklentiyi kapatma işlemi gecikmeden yapılmalıdır, aksi halde bu sunucunun arkasındaki hizmetler de risk altında kalır.

ÖzetTürkçe

Apache APISIX'in batch-requests eklentisindeki bir hata nedeniyle istemci IP adresini gerçek uzak IP ile değiştirmesi gereken kontrol atlatılabiliyor ve X-REAL-IP başlığı ezilebiliyor. Saldırgan bu yolla Admin API'nin IP kısıtlamasını aşabilir. Varsayılan yapılandırmada (varsayılan API anahtarı ile) bu durum uzaktan kod çalıştırmaya yol açar. 1.3 ve üzeri, 2.10.4 öncesi ile 2.12.1 öncesi sürümler etkilenir.

Saldırgan ne yapabilir?

Kimlik doğrulaması olmadan ağ üzerinden saldırgan Admin API IP kısıtlamasını aşıp varsayılan yapılandırmalarda uzaktan kod çalıştırabilir. Yönetici anahtarı veya Admin API portu değiştirilmiş olsa bile veri düzlemindeki IP kısıtlamaları aşılabilir.

Kaynaktaki açıklama (İngilizce)

An attacker can abuse the batch-requests plugin to send requests to bypass the IP restriction of Admin API. A default configuration of Apache APISIX (with default API key) is vulnerable to remote code execution. When the admin key was changed or the port of Admin API was changed to a port different from the data panel, the impact is lower. But there is still a risk to bypass the IP restriction of Apache APISIX's data panel. There is a check in the batch-requests plugin which overrides the client IP with its real remote IP. But due to a bug in the code, this check can be bypassed.

Üreticinin geçici önlemi (İngilizce)

1. explicitly configure the enabled plugins in conf/config.yaml, ensure batch-requests is disabled. (Or just comment out batch-requests in conf/config-default.yaml)
Or
1. upgrade to 2.10.4 or 2.12.1.

CISA'nın önerdiği eylem (İngilizce)

Apply updates per vendor instructions.

Ne yapmalı?

  1. Apache APISIX'i 2.10.4 veya 2.12.1 sürümüne yükseltin. Üretici
  2. Hemen yükseltme yapamıyorsanız conf/config.yaml dosyasında etkin eklentileri açıkça tanımlayın ve batch-requests eklentisinin devre dışı olduğundan emin olun (veya conf/config-default.yaml içinde batch-requests satırını yorum satırı yapın). Üretici
  3. Satıcı talimatlarına uygun şekilde güncellemeleri uygulayın. CISA

Ek önlemler

  • Admin API için varsayılan API anahtarını mutlaka değiştirin ve güçlü, benzersiz bir anahtar kullanın. Genel öneri
  • Admin API'yi veri düzleminden farklı bir porta taşıyın ve erişimi güvenlik duvarıyla yalnızca güvenilir yönetim ağlarına açın. Genel öneri
  • Erişim günlüklerinde batch-requests uç noktasına gelen şüpheli istekleri ve beklenmeyen Admin API değişikliklerini izleyin. Genel öneri

Bu açık kişisel verilerin sızmasına yol açabilir. Sistemlerinizde kullanıldığından şüpheleniyorsanız KVKK'daki ihlal bildirimi yükümlülüğünüzü (Kurul'a 72 saat içinde bildirim) hukuk danışmanınızla birlikte değerlendirin. Bu not hukuki tavsiye değildir.

Etkilenen sürümler1 yazılım

YazılımEtkilenenDüzeltildiği sürüm
Apache Software Foundation Apache APISIX < 2.12.1 2.12.1
< 2.10.4 2.10.4
≥ 1.3 –

Kaynaklar6 kaynak

Kayıt geçmişi

  1. CISA KEV listesine eklendi (saldırılarda kullanılıyor)
  2. Yayımlandı

İlgili açıklar

Türkçe metin, resmi kayıtlardaki bilgilerle yapay zekâ yardımıyla yazıldı ve yayından önce otomatik kontrollerden geçti. Bir değişikliği uygulamadan önce üreticinin duyurusuna mutlaka bakın.