- Aktif istismar
- Yama var
- CWE-94
CVE-2018-7602
Drupal çekirdeğinde uzaktan kod çalıştırma açığı
- Yayımlandı
- Güncellendi
- 1 Eki 2026
- Açık yaşı
- 3022 gün
- Kaydı açan
- drupal
ÖzetTürkçe
Drupal 7.x ve 8.x sürümlerinin birden fazla alt sisteminde uzaktan kod çalıştırma açığı bulunmaktadır. Bu açık, saldırganların bir Drupal sitesinde birden fazla saldırı vektörünü kullanmasına olanak tanıyarak sitenin ele geçirilmesine yol açabilir. Bu açık, SA-CORE-2018-002 ile ilişkilidir. Hem SA-CORE-2018-002 hem de bu açık, gerçek dünyada aktif olarak istismar edilmektedir.
Kaynaktaki açıklama (İngilizce)
A remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially allows attackers to exploit multiple attack vectors on a Drupal site, which could result in the site being compromised. This vulnerability is related to Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-002. Both SA-CORE-2018-002 and this vulnerability are being exploited in the wild.
Üreticinin çözüm notu (İngilizce)
Solution:
Upgrade to the most recent version of Drupal 7 or 8 core.
If you are running 7.x, upgrade to Drupal 7.59.
If you are running 8.5.x, upgrade to Drupal 8.5.3.
If you are running 8.4.x, upgrade to Drupal 8.4.8. (Drupal 8.4.x is no longer supported and we don't normally provide security releases for unsupported minor releases. However, we are providing this 8.4.x release so that sites can update as quickly as possible. You should update to 8.4.8 immediately, then update to 8.5.3 or the latest secure release as soon as possible.)
If you are unable to update immediately, or if you are running a Drupal distribution that does not yet include this security release, you can attempt to apply the patch below to fix the vulnerability until you are able to update completely:
Patch for Drupal 8.x (8.5.x and below)
Patch for Drupal 7.x
These patches will only work if your site already has the fix from SA-CORE-2018-002 applied. (If your site does not have that fix, it may already be compromised.)
CISA'nın önerdiği eylem (İngilizce)
Apply updates per vendor instructions.
Bu açığın açıklamasını Türkçeye çevirdik. Adım adım çözüm önerilerini kritik ve yeni açıklar için hazırlıyoruz; düzeltilmiş sürüm aşağıdaki tabloda, ayrıntılar üreticinin duyurusunda.
Etkilenen sürümler1 yazılım
| Yazılım | Etkilenen | Düzeltildiği sürüm |
|---|---|---|
| Drupal Core | < 7.59 | 7.59 |
| < 8.5.3 | 8.5.3 | |
| < 8.4.8 | 8.4.8 |
Kaynaklar9 kaynak
- CVE.org kaydı
- NVD kaydı
- debian.org/security/2018/dsa-4180 Üretici bülteni
- exploit-db.com/exploits/44557 İstismar kodu ya da analiz
- exploit-db.com/exploits/44542 İstismar kodu ya da analiz
- securitytracker.com/id/1040754 Diğer
- lists.debian.org/debian-lts-announce/2018/04/msg00030.html Diğer
- drupal.org/sa-core-2018-004 Diğer
- securityfocus.com/bid/103985 Diğer
Kayıt geçmişi
- CISA KEV listesine eklendi (saldırılarda kullanılıyor)
- Yayımlandı
İlgili açıklar
Türkçe metin, resmi kayıtlardaki bilgilerle yapay zekâ yardımıyla yazıldı ve yayından önce otomatik kontrollerden geçti. Bir değişikliği uygulamadan önce üreticinin duyurusuna mutlaka bakın.